30 de jul. de 2008

Configuracion de router Cisco

CCNA 1

En esta entrada pondre comandos de configuracion de los router Cisco para no olvidarlos.
En el curso de ccna he aprendido bastante configuracion sobre los router cisco y aqui espero escribir gran parte de esta.

En primer lugar nombrare los estados de configuracio:

En caso de que pida alguna clave saldra algo como:
Password:


el primer estado es el de usuario (este no tiene privilegios de configuracion):
ROUTER>

para entrar al estado de usuario privilegiado tecleamos:

ROUTER>enable
ROUTER#
(este es el modo de usuario privilegiado)

Para cambiar la configuracion del router es necesario teclear:
ROUTER#configure terminal
ROUTER(config)#


Ahora comenzaremos con la configuracion basica:
ROUTER(config)#hostname R1 (este comando cambia el nombre del router a R1)
R1(config)#
R1(config)#enable password cisco (establecemos la password del modo privilegiado como cisco)

Configuraremos una interface serial:
R1#configure terminal
R1(config)#interfase serial 0/0/0 (especificcamos cual interfase serial)
R1(config-if)#ip address 192.168.1.1 255.255.255.0 (establecemos la ip y mascara)
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown
(prendemos la interface)
R1(config-if)#exit(volver al modo config)
R1(config)#exit (volver al modo privilegiado)
R1#write (guardamos)

EN EL CASO DE UNA INTERFASE FASTETHERNET:
Router#
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.1.1.10 255.255.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#exit
Route#write



Relacionar un nombre de host con una ip
Supongamos el siguiente caso


Nos ubicamos en el router Santiago (esto es despues de tener las interfaces configuradas).

Santiago#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Santiago(config)#ip host London 192.168.1.1


Con esto podriamos aserle ping al host london
Santiago#ping London

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 21/35/50 ms

Santiago#


Comandos Utiles:

Router#erase startup-config
(Borra la memoria del router NVRAM)
Router#show startup-config (Muestra la memoria guardada del router NVRAM)
Router#show running-config (Muestra la memoria del router RAM)
Router#reload (Reinicia el router)
Router#show version (muestra la version del sistema operativo del router)
Router#show flash: (muestra la capacidad y los nombres del sistema operativo)
Router#copy origen destino (copiar desde "origen" hasta "destino")
Router#show ip route (vizualiza tabla de rutas de la maquina)
(para eliminar un comando anteponemos no al comando)
ej: Router#no router rip


Romper password al router

En caso de que tengamos un router el cual tiene password y no la tenemos, podemos ingresar de la siguiente manera:

Al iniciar el router presionamos CTRL+PAUSA
El resultado deberia ser algo como esto, de esta manera entramos en el modo rommon del router.

Self decompressing the image :
#############
monitor: command "boot" aborted due to user interrupt
rommon 1 >

Luego escrivimos los siguientes comandos

rommon 1 > CONFREG 0X2142 (cambiamos el numero de registro de configuracion)
rommon 2 > RESET


--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: NO


Press RETURN to get started!
Router>enable
Router#copy startup-config running-config


Luego le podemos cambiar la pass y la secret. de la siguiente manera ("xxx" pondremos nuestras password)

Router(config)#enable password xxx
Router(config)#enable secret xxx

volvemos el numero confreg a como estaba por defecto
Router(config)#config-register 0x2102

Y por ultimo guardamos
Router#write

Configuracion sistemas de enrutamiento

Rip
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 192.168.1.1
(se le indican las redes directamente conectadas)

Rip Version 2
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.1 (se le indican las redes directamente conectadas)

De a poco ire subiendo mas info cuando tenga tiempo
pero aqui ahi un manual que encontre

http://asignaturas.diatel.upm.es/rrss1/documentacion_archivos/LABORATORIO%20ACTUAL/manual_rapido_cisco.pdf

1 comentario:

Anónimo dijo...

muy buena aporte a configuracion de route......podrias poner un archivo de asignacion de ip dhcp para pc cableada inalabrica y epones te lo agradeceria muncho.......